Поиск по блогу :

    3 марта 2009 г.

    Ошибка 'system-tools-backends...' при использовании Synaptic

    Недавно переустановил убунту 8.10 и столкнулся со следующей проблемой. При попытке установить любую программу из синаптика, после установки вылетает окошко с ошибкой

    E: system-tools-backends: подпроцесс post-installation script возвратил код ошибки 1
    При этом, установленные таким образом пакеты, работают нормально.
    Но постоянно выскакивающее сообщение меня раздражало и я начал искать решение проблемы. Решение нашлось не сразу...

    Решение проблемы

    $ $
    sudo invoke-rc.d system-tools-backends stop
    sudo dpkg --configure -a

    После этого, сообщение с ошибкой пропало :)