Поиск по блогу :

    11 октября 2010 г.

    Ubuntu 10.10 и мышка A4Tech XL-750BH

    Я, как и многие, сразу же, после выхода Ubuntu 10.10, обновил свою систему. Но... Как-то после стабильной 10.04 я уже и не ожидал увидеть такой вот противный баг, который всплыл у меня после обновления системы.
    Дело в том что после апгрейда системы и последующей после нее перезагрузки, у меня стала странно себя вести мышка A4Tech XL-750BH. Перестала работать левая, средняя и боковые клавиши. Работала только правая :)

    Решение проблемы

    1. Первый способ. Самый надежный.
    1.1. Нужно обновить пакет xserver-xorg-input-evdev.
    1.2. Берем обновленный пакет, например, отсюда - launchpad.net/~xorg-edgers/+archive/ppa/+packages, устанавливаем, перегружаемся и больше не имеем проблем с мышкой.
    1.3. Единственный неприятный момент, это то, что после первой перезагрузки, может вообще перестать работать и мышь и клавиатура. Решается еще одной перезагрузкой. Больше эта проблема - не повторяется.

    2. Второй способ.
    2.1. Выполнить в терминале команду:

    $
    xinput set-int-prop %id% "Device Enabled" 8 0

    где %id% - это id вашей мышки полученный из списка:
    $
    xinput --list

    У меня это была строка:
    ↳ A4TECH USB Device id=10 [slave pointer (2)]
    1.2. Минус этого способа в том, что он работает только до перезагрузки системы.

    3. Третий способ, который мне помог, заключается в отключении led-индикации, при переключении раскладки клавиатуры (ну кто бы мог подумать, что это может решить проблему :)
    3.1. Заходим в 'Система'>'Параметры'>'Клавиатура' и на вкладке 'Раскладки' нажимаем кнопку 'Параметры'
    3.2. В пункте 'Использовать клавиатурные индикаторы для отображения дополнительных раскладок' убираем все галочки с чекбоксов.
    3.3. После перезагрузки, мышка должна нормально работать.
    3.4. Из минусов - не у всех и не всегда срабатывает.

    P.S. Вот тема, посвященная этой баге в Launchpad багтрекере.

    Обновлено 12.10.2010г. в 2:19